Ruby Versions

For now Jelastic supports four Ruby versions:

  • 1.9.3-p551
  • 2.0.0-p643
  • 2.1.5
  • 2.2.2

You can choose the one you need while environment creation and easily switch between them afterwards. To do this follow the instruction:

  1. While creating environment choose the desired application server (Apache or NGINX).

  1. In the second drop-down list choose the version of Ruby (1.9.3, 2.0.0, 2.1.5 or 2.2.2) you want to use. Then specify cloudlets limit for app server, enter the name of your environment and click Create.


  1. You can also change the version of Ruby in the already existing environment:

  • Click Change environment topology button next to the environment.

  • Choose another version you require and click Apply.

What's next?