Jelastic 6.0.6

This document is preliminary and subject to change.

In this document, you will find all of the new features, enhancements and visible changes included to the Jelastic PaaS 6.0.6 release.

Kubernetes Cluster Domain Length Validation

Adjusted domain length validation for the Kubernetes Cluster package due to official requirementsLearn more

Software Stack Versions

Actualized list of supported OS templates and software stack versionsLearn more

Fixes Compatible with Prior Versions

Bug fixes implemented in the current release and integrated to the previous Jelastic versions through the appropriate patchesLearn more

Bug Fixes

List of fixes applied to the platform starting from the current releaseLearn more

Kubernetes Cluster Domain Length Validation

The total length of the container hostname is limited to 64 characters due to the Linux specifics. Jelastic PaaS automatically validates this value during environment creation. However, for Kubernetes instances, the requirement is a bit lower - 63. So, starting with the platform 6.0.6 release, such nuance is correctly considered during the Kubernetes Cluster package creation to avoid possible errors due to incorrect domain length.

Kubernetes domain length

Back to the top

Fixes Compatible with Prior Versions

Below, you can find the fixes that were implemented in the Jelastic 6.0.6 release and also integrated into previous Jelastic versions by means of the appropriate patches.

Jelastic 6.0.6
#Compatible fromDescription
JE-580493.3Rate limit error for custom domains should be handled during the Let’s Encrypt add-on installation
JE-581543.3A test SSL certificate is provided for the GitLab application when reconfiguring the Let’s Encrypt add-on to a new domain
JE-538265.0.5Incorrect admin console link on the home page of the WildFly cluster if the environment name include non-English characters
JE-567915.0.5Version-specific configs are missing on the WildFly 20 and 21 application servers
JE-571525.0.5An error occurs when redeploying the Ruby application server to a lower version
JE-577415.0.5The Node-RED Dev application is inaccessible after deployment from the Marketplace
JE-587735.0.5An error occurs when trying to clone an environment with a Tomcat cluster
JE-588045.0.5Typo in the resource name in the ssl.upstreams.inc configuration file on the NGINX load balancer
JE-521575.3.2An error occurs when switching to the Runtime tab in the WildFly 17 and 18 admin panel
JE-585445.4The “jem vcs update” error occurs on the Golang application server when deploying some applications
JE-552615.7The administration panel for the WildFly 21 cluster is inaccessible via the DAS node on the Jelastic 5.7 platforms
JE-576395.7Webhook of the Git-Push-Deploy add-on fails to trigger project updates

Back to the top

Software Stack Versions

The software stack provisioning process is independent of the platform release, which allows new software solutions to be delivered as soon as they are ready. However, due to the necessity to adapt and test new stack versions, there is a small delay between software release by its respective upstream maintainer and integration into Jelastic PaaS.

The most accurate and up-to-date list of the certified software stack versions can be found on the dedicated documentation page.

More info

Back to the top

Bug Fixes

In the table below, you can see the list of bug fixes applied to the platform starting from Jelastic 6.0.6 release:

Jelastic 6.0.6
#Affected VersionsDescription
JE-582815.9.3Iptables rules are not removed on the Ubuntu VPS after disabling the firewall via the dashboard
JE-582846.0.2Duplicate iptables entries in firewall after the Ubuntu VPS redeploy
JE-58682-An error occurs during environment migration between regions
JE-58716-Custom firewall rules are added incorrectly on the Ubuntu VPS nodes
JE-58839-An error occurs when trying to access the container file manager via the dashboard

Back to the top