NetBeans Plugin Installation

In order to start working with the Jelastic NetBeans plugin, you need to get it installed and connect to your Jelastic account within its settings.

So, launch your NetBeans IDE and proceed with the instructions below.

Plugin Installation

1. Run the latest version of NetBeans IDE (Java EE or All bundle) and navigate to the Tools > Plugins menu item.

netbeans add plugin
2. Switch to the Available Plugins tab and enter jelastic in the Search field. Choose Jelastic Netbeans Plugin in the list and click the Install button.

jelastic netbeans plugin
3. Click the Next button in the appeared window.

confirm plugin installation
4. Read and accept the terms of the license agreement with the appropriate check box.

plugin license agreement

Click Install to proceed.

5. After installation success, close the window with the Finish button.

finish plugin installation
Tip: Before the last step you may need to Verify Certificate for the Jelastic plugin, click the Continue button to proceed.

plugin verify certificate
Now, you have Jelastic Plugin in your NetBeans IDE.

Connect to Jelastic Account

1. Navigate to the Window > Services menu item.

netbeans services window
2. Within the opened section, right-click on the Cloud line and add a new cloud.

netbeans add cloud
3. Choose Jelastic in the list of cloud providers and click Next.

netbeans add jelastic
4. In the opened window specify Display name (any preferable name, for example, myjelastic), choose (from the drop-down list) or type your hosting Provider domain, and fill in Login and Password fields with Jelastic credentials.

add account credentials

Click Finish to establish connection.

5. Now, if you expand the Cloud list, you will see a new one with the name you’ve specified.

jelastic added to netbeans
Note: To delete your cloud from NetBeans IDE, navigate to Tools > Cloud Providers. Within the opened window, choose Jelastic installation and click the Remove Cloud button.

netbeans remove cloud
Now, as you have the Jelastic NetBeans plugin installed and connection established, you can proceed to environments management and projects deployment.