Java Versions

When setting up an environment in Jelastic PaaS you can choose the distribution and version of JDK you want to run:

  • AdoptOpenJDK: 8.0.275; 11.0.9; 13.0.2; 14.0.2; 15.0.1
  • Amazon Corretto: 8.275.01.1; 11.0.9.12.1; 15.0.1.9.1
  • Eclipse OpenJ9: 0.11.0 (8u192-b12; 11.0.1); 0.15.1 (8u222-b10; 11.0.4); 0.17.0 (8u232-b09; 11.0.5; 13.0.1); 0.18.1(8u242-b08; 11.0.6; 13.0.2) 0.20.0 (8u252-b09; 11.0.7); 0.21.0 (8u262-b10; 8u265-b01; 11.0.8; 14.0.2); 0.22.0 (15.0.0); 0.23.0 (8u272-b10; 11.0.9)
  • GraalVM CE (currently, for Java Engine and Maven only): 19.0.0; 19.1.1; 19.2.1; 19.3.1
  • Liberica JDK: 8.0.262; 11.0.8; 13.0.2; 14.0.2
  • Oracle JDK Dev: 7.0_79; 8.0_202; 11.0.2
  • Oracle OpenJDK: 7.0.261; 8.0.252; 11.0.4; 13.0.2; 14.0.2; 15.0.1; 16.ea-b23
  • Zulu Community: 7.0.282; 8.0.272; 11.0.9; 13.0.5; 14.0.2; 15.0.1
The up-to-date list of the releases available at Jelastic PaaS is provided via the dedicated, regularly (weekly) updated Software Stack Versions document.

Also, for the existing environments the used engine version can be easily switched to a different one:

1. Log into the Jelastic dashboard and click the New Environment button.

new Java environment

Within the opened wizard, switch to the Java tab, pick the desired application server and engine versions (as it is shown in the image above).

2. To change the version of Java in the already existing environment, redeploy the appropriate container(s):

redeploy Java version

Just, select the required Tag (stack and JDK distribution versions) and click Redeploy.

Confirm an action within the appeared pop-up and wait a few minutes for the changes to be applied.

What’s next?