NetBeans IDE Plugin User Manual

NetBeans is a free and open-source integrated development environment (IDE). It supports development of all Java application types (Java SE, Java ME, web, EJB and mobile applications) out of the box.

All the functions of the IDE are provided by modules, which allow NetBeans IDE to be extended. Each module provides a well defined function, such as support for the Java language, editing, support for the CVS or SVN versioning system. NetBeans IDE contains all the modules needed for Java development in a single download, allowing the user to start working immediately.

Jelastic team has created a plugin for NetBeans development platform that simplifies the process of application management and development in Jelastic Cloud platform.

Use the following instructions to install the plugin and manage Jelastic environments through NetBeans IDE:

Plugin installation
Adding Jelastic cloud in NetBeans IDE
Working with existing Jelastic environments via NetBeans IDE
Creating and deploying web project via NetBeans IDE

Plugin Installation

  1. Run the latest version of NetBeans IDE (Java EE or All bundle) and navigate to Tools > Plugins menu item.


  2. Open Available plugins tab and enter jelastic in the Search field.
  3. Jelastic Plugin will appear in the list. Choose it and click Install button.


  4. Start the installation by clicking Next button in the appeared window.


  5. Accept the terms in all of the license agreements and click Install.


  6. Installation is successfully completed. Click Finish button to close the installation window. Now you have Jelastic Plugin in your NetBeans IDE.

Adding Jelastic Cloud in NetBeans IDE

  1. Navigate to the Window > Services menu item.


  2. Right-click on the Cloud menu to add a new cloud.


  3. Choose Jelastic in the list of cloud providers. Click Next.


  4. In the opened window specify New name (name of your cloud, for example, myjelastic), choose Provider (you hoster's domain) from the drop-down list, and fill in Login and Password fields with Jelastic credentials.


  5. Now, if you expand the Cloud list, you will see your cloud with the name you've specified.


  6. You can delete your cloud only after adding the project (more detailed information is stated in the Note).

Working with Existing Jelastic Environments via NetBeans IDE

Now you can easily manage your environments through Services tab.

For that expand your Cloud list and choose the desired environment.


  • Stop/start environment

  • 1. To stop the environment right-click on it and choose Stop environment.


    2. If you want to run already stopped environment, right-click on it and choose Start environment.


  • Work with log files

  • 1. You can easily manage and download log files. Just expand log folder of the needed node, double click or right-click on the desired log and choose Get log item.


    2. Log file will be automatically opened.


    3. If you want to save log file, choose the File > Save as menu item.


  • Work with the application contexts

  • 1. Right-click on the context in the environment to open your application in the browser.

    2. Also using this menu you can delete the chosen context.

Creating and Deploying Web Project via NetBean IDE

You can create your own project in NetBeans IDE and deploy it right to the Jelastic environment. 

  • Create a new project

  • 1. Click New Project button in the upper tool panel of NetBeans IDE.


    2. Choose the Java Web category and Web Application project. Click Next.


    3. In the opened window enter the desired Project Name, specify Project Location and Project Folder. Click Next.


    4. Select one of your environments in the Server drop-down list. Specify the context, if it is needed, and click Next.


    5. As a last step check the necessary frameworks (if you need any) and click Finish.


    6. Your new web project is successfully created.


  • Deploy your project

  • 1. Right-click the name of your project at the left-hand panel and choose Deploy menu item.


    2. After that .war archive of your project will be built and sent to the Jelastic cloud.


    3. To make sure everything works:
    • enter the URL of your application in the browser
    • or navigate to Services tab > Cloud list. Right-click on the context of your environment and choose Open App in browser.


    As a result your application will be opened.

Note

You can delete your cloud only if you have already added your project:
  1. Navigate to Tools > Cloud Providers.


  2. Choose the cloud and click Remove Cloud button.


  3. That's all, your cloud is deleted.

    With Jelastic NetBeans IDE plugin installed you can easily manage, develop and deploy your applications without switching between the IDE and the browser.

    Use all the advantages of Jelastic and NetBeans IDE integration!